冬季救援安装FAQ

来自TeamMoeg官方WIKI
跳到导航 跳到搜索
本页面与Icon banner TWR.png相关
Icon banner dev.png 本页面内容系TWR开发人员撰写。
在声明有效的版本区间内,您可以放心采信本页面的内容。


我不会安装,在哪下载[编辑 | 编辑源代码]

可以在CF,MCBBS,官方Q群下载整合包,并建议使用java8u311或jdk12.0.1游玩,请勿使用Java 17或者更高的版本以及Java8 321或者更高的版本游玩。

*0.5.0版本新的安装理论上已经支持java8u321,但是不确定是否100%生效。

对于国内玩家,我们推荐使用官方Q群群文件下载和MCBBS上的网盘下载,从CF下载需要一定的操作和技术,我们不保证从CF下载的整合包能在国内正常使用。

由于CF封禁了第三方API,我们现在已经不能提供serverstarter工具进行自动安装整合包,请按照下文自行安装。

安装方法[编辑 | 编辑源代码]

1. 根据你的系统,打开HMCL启动器

2. 输入账号或者游戏名称

3. 将你下载所得的压缩包拖入HMCL启动器窗口内

4. 点击安装并等待安装完成

5. 如果第四步下载卡住,取消下载,点击左下角的命令方块图标"设置",将“下载源”改为MCBBS,然后重新进行第三步

安装失败[编辑 | 编辑源代码]

请从我们的官方渠道下载安装,不要相信任何人(包括朋友)转给你的整合包,自行打包很可能导致安装失败。

游戏进不去,崩溃[编辑 | 编辑源代码]

1、重启游戏

2、如果依然崩溃请调整内存再开游戏,推荐调整到6-8G,并且确定调整的内存小于你电脑的可用内存

3、如果依然不行请重启电脑再试

4、还有问题请重新安装整合包。

存档进不去,卡住/崩溃[编辑 | 编辑源代码]

1、请耐心等待,正常游戏打开和电脑性能有关,如果处理器较差或者内存较低,可能需要几分钟时间才能载入。

2、如果几分钟没有反应,请先按照“游戏进不去”进行解决。

3、如果还不能解决请删除存档文件夹下的/serverconfig文件夹,再尝试进入。

服务器开服崩溃[编辑 | 编辑源代码]

1、请检查Java版本,一般需要使用Java8u311或者jdk12.0.1,请确保完全一致。

2、检查是否删除所有客户端模组(后文有写),请人工核对一遍,不要用搜索功能,因为模组文件名称可能和给出的有一定偏差,如果没找到对应的模组,则可能是已经移除,无需额外再删除。

3、检查内存分配,请确定内存足以用来游玩。

4、如果依然崩溃请使用最新版本。

5、本整合包已在Mohist,Arclight双端测试确保能够启动和进服,并且基本上能稳定运行,如果不能开服请自行排查,与整合包没有关系。

最新兼容版本:

  • Mohist 1.16.5-1082
  • Arclight 1.16.5-1.0.21

推荐使用比这些更新的服务端版本,这样能尽可能避免出现bug。我们不推荐使用除了这些和forge服务端以外的任何服务端,因为它们很多已经停止维护并且有很多问题。

进服显示Failed to sync...[编辑 | 编辑源代码]

原因一般是kubejs或者mod版本不一致,按以下方法排查

0、请尝试重启客户端和服务端,首次安装可能会出现版本识别异常的情况。Curseforge下载的版本有可能不能与群里下载的版本联机,请确保版本完全一致。

1、请确定服务端和客户端的mod一致,并且删除了后文所述的客户端模组。请不要自信完全一致,必须再检查几遍,并且确定没有在启动器里面关闭任何模组。

2、请确保客户端或者服务端的kubejs config文件夹完全一致,手动安装记得复制这两个文件夹尤其是kubejs文件夹。

3、重启客户端服务端,还不能解决则是网络问题。

进服显示Mismatch mod channel list[编辑 | 编辑源代码]

原因一般是冬季救援整合包版本不一致、mod版本不一致或者mod列表不一致

1、删除服务器端的mods config kubejs文件夹并从客户端复制过去,记得一定要先删除再覆盖,然后删除mcbbs贴文所述内容。

2、查看客户端日志,找出不匹配的模组,并更改为匹配的模组。

3、请确保整合包客户端版本与服务端版本完全一致,不要擅自修改文件、更新模组。

4、在服务端和客户端日志搜索“FH Network Version:”这个字符串,确定客户端和服务端版本是一致的。

权限组问题/服务器问题[编辑 | 编辑源代码]

我们(开发组成员)并不具备相关知识和能力来处理这些问题,因此我们不负责任何此类问题,一切可能遇到的问题都请自行处理和修复。

权限问题我们推荐给您信任的用户op即可解决。服务器相关崩溃/错误请在单人测试,若单人中不存在此类问题我们也无法解决。

我是单机玩家,如何更新到最新版本[编辑 | 编辑源代码]

1. 删除旧版本.minecraft里面的mods和kubejs文件夹,然后mods文件夹用新版压缩包里的mods文件夹替换。

2. 开启游戏然后在更新提示界面选择继续游戏即可。(如果遇到问题请退出重开)

我是公益服主,如何更新到最新版本[编辑 | 编辑源代码]

1. 把你服务器里的mods和kubejs文件夹删了,用解压后新版的mods文件夹替换。

2. 删除mods文件夹里的所有客户端模组(后续有写)

3. 开启服务器即可。

我找不到mods文件夹/我想重新安装来更新[编辑 | 编辑源代码]

如果您因为手动替换mod麻烦或者其它原因,选择直接安装新版本整合包的,我们强烈建议手动复制游戏目录内的以下文件到新整合包:

1. local文件夹(小地图mod的地图,不复制地图重置)

2. usercache.json和usernamecache.json(仅非正版玩家需要,不复制可能导致领地和任务重置,正版玩家则不需要)

3. saves文件夹(游戏存档)

以下文件也有可能需要:

1. resourcepack shaderpack(资源包和光影)

2. schematics(机械动力保存的蓝图)

常见多人游戏问题与解决方法一览[编辑 | 编辑源代码]

  • 多人服务器中,死亡后衣服与部分装备消失,有以下办法:
    1. 可以打开服务器的死亡不掉落。
    2. 在world/serverconfig/frostedheart-server.toml中,把keepEquipments设置为false,注意每次更新之后都需要重新设置。
    3. 推荐使用forge服务器端
  • 多人游戏中没有权限进行组队:
    1. 安装权限插件并自行配置相应权限。
    2. 给予所有人op。

附录:客户端模组列表[编辑 | 编辑源代码]

ClientTweaks

drippyloadingscreen

fancymenu

konkrete

lightfallclient

Mousetweaks

notenoughanimations

performant

ponderjs

shutupexperimentalsettings

Tips

TRansliterationLib

JustEnoughCharacters

Configured

以上模组大小写和名字不一定完全一致,部分模组可能随着更新被删除或者更改,请自行检查。